vimでTypeScriptのSyntaxHighlightに対応したいっ!

Vimプラグインマネージャー

元々インストールしたままのvimで一部の設定は.vimrcに書いていましたが、とりあえずVundle(vimプラグインマネージャー)をインストールします。

Vundle.vimをclone

git clone https://github.com/VundleVim/Vundle.vim.git ~/.vim/bundle/Vundle.vim

.vimrc設定

set nocompatible
filetype off
set rtp+=~/.vim/bundle/Vundle.vim
call vundle#begin()

Plugin 'VundleVim/Vundle.vim'

" typescript
Plugin 'leafgarland/typescript-vim'

call vundle#end()
filetype plugin indent on

" 元々書いてあった.vimrcはここから下に残しておく
" ...

インストール

vimを起動してインストールもできるみたいですが、今回はコマンドラインから。

vim +PluginInstall +qall

これでバリバリtsの開発ができますねっ!
新しいPCに買い替えたらVScodeにするかもしれませんが・・。

参考

Vim におけるプラグイン管理についてまとめてみた – Qiita
Vim で TypeScript のカラースキーマに対応する – Qiita

返信を残す

メールアドレスが公開されることはありません。

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください